[SOLVED] Issue connecting to Ender-3 with SKR Mini board on /dev/ttyACM0

We’re just trying to get our 3dPrinterOS install up and running.

I have a Creality Ender-3 using a BTT SKR Mini E3 V2.0 board, and the 3dprinteros client running on a Raspberry Pi (generated image from the website) won’t detect it. I’ve tried plugging the printer into my Linux laptop, and it’s detected fine and can be controlled via Cura, using the same cable. I’ve also tried swapping the same cable from the Pi client to a known-good CR10S4, and the client detects that printer fine. So… the cable works, the Pi and client work with other printers, the printer works with other clients.

The only thing I can find different is that the Ender 3 board is recognized by Linux as an ACM device and assigned /dev/ttyACM0 instead of /dev/ttyUSB0. I can’t find any setting that controls what device the client is checking for a printer, and I also don’t see anything about that in the log (even at debug level).

Has anyone run into this? Is it a known bug?


Looks like 3DPrinterOS Client don’t know you board’s USB Vendor ID and Product ID(VID/PID).
You can ether:
a) Get them by running lsusb command and sending the output here as a simple forum message.
b) Create semi-automatic printer addition request from a local web UI of the machine that the printer is connected to.
To do so open the Web UI by typing LAN IP address of your RPI into browser or for a localhost machine.
Then go Settings/Add new printer type. And follow direction from the wizard.

Best regards, 3DPrinterOS Team.

Thank you, Vladimir.

I tried the wizard but it doesn’t work. It gives me the detection wizard warning screen and I click “Proceed”, and it just… goes right back to the same page. Click Proceed, and it spins for a minute and then goes right back.

The device in question shows up in lsusb as:

1eaf:0004 Leaflabs Maple serial interface


@Vladimir It looks like we’ve made some progress since this morning; the client is now talking to the printer but still showing “No printers connected”. Here are the logs from the time that it received an update:

2022-07-13 12:27:06,489 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/run Printer interface was stopped
2022-07-13 12:27:06,488 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/close_printer_sender ...closed.
2022-07-13 12:27:06,487 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/close Threaded sender is closed
2022-07-13 12:27:06,486 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/close ...done
2022-07-13 12:27:06,479 TemperatureThread/temperature_requesting Temperature requesting loop finish
2022-07-13 12:27:06,478 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/close_printer_sender Closing {'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}
2022-07-13 12:27:06,476 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/connect_to_printer Successful connection to Generic Marlin!
2022-07-13 12:27:06,476 TemperatureThread/temperature_requesting Starting temperature requesting loop
2022-07-13 12:27:06,474 Read thread/log_strange_acks Received: b'Cap:CONFIG_EXPORT:0'
2022-07-13 12:27:06,471 Read thread/log_strange_acks Received: b'Cap:MEATPACK:0'
2022-07-13 12:27:06,469 Read thread/log_strange_acks Received: b'Cap:COOLER_TEMPERATURE:0'
2022-07-13 12:27:06,466 Read thread/log_strange_acks Received: b'Cap:CHAMBER_TEMPERATURE:0'
2022-07-13 12:27:06,463 Read thread/log_strange_acks Received: b'Cap:BABYSTEPPING:1'
2022-07-13 12:27:06,460 Read thread/log_strange_acks Received: b'Cap:ARCS:0'
2022-07-13 12:27:06,458 Read thread/log_strange_acks Received: b'Cap:MOTION_MODES:0'
2022-07-13 12:27:06,456 Read thread/log_strange_acks Received: b'Cap:THERMAL_PROTECTION:1'
2022-07-13 12:27:06,453 Read thread/log_strange_acks Received: b'Cap:EXTENDED_M20:1'
2022-07-13 12:27:06,450 Read thread/parse_printer_answers Firmware info: b'Cap:CUSTOM_FIRMWARE_UPLOAD:0'
2022-07-13 12:27:06,447 Read thread/log_strange_acks Received: b'Cap:LFN_WRITE:0'
2022-07-13 12:27:06,444 Read thread/log_strange_acks Received: b'Cap:LONG_FILENAME:1'
2022-07-13 12:27:06,442 Read thread/log_strange_acks Received: b'Cap:AUTOREPORT_SD_STATUS:0'
2022-07-13 12:27:06,438 Read thread/log_strange_acks Received: b'Cap:SD_WRITE:1'
2022-07-13 12:27:06,436 Read thread/log_strange_acks Received: b'Cap:REPEAT:0'
2022-07-13 12:27:06,434 Read thread/log_strange_acks Received: b'Cap:MULTI_VOLUME:0'
2022-07-13 12:27:06,432 Read thread/log_strange_acks Received: b'Cap:SDCARD:1'
2022-07-13 12:27:06,430 Read thread/log_strange_acks Received: b'Cap:PROMPT_SUPPORT:0'
2022-07-13 12:27:06,427 Read thread/log_strange_acks Received: b'Cap:HOST_ACTION_COMMANDS:0'
2022-07-13 12:27:06,424 Read thread/log_strange_acks Received: b'Cap:EMERGENCY_PARSER:1'
2022-07-13 12:27:06,420 Read thread/log_strange_acks Received: b'Cap:CASE_LIGHT_BRIGHTNESS:0'
2022-07-13 12:27:06,416 Read thread/log_strange_acks Received: b'Cap:TOGGLE_LIGHTS:0'
2022-07-13 12:27:06,413 Read thread/log_strange_acks Received: b'Cap:SOFTWARE_POWER:0'
2022-07-13 12:27:06,410 Read thread/log_strange_acks Received: b'Cap:BUILD_PERCENT:1'
2022-07-13 12:27:06,407 Read thread/log_strange_acks Received: b'Cap:LEVELING_DATA:1'
2022-07-13 12:27:06,403 Read thread/log_strange_acks Received: b'Cap:Z_PROBE:0'
2022-07-13 12:27:06,400 Read thread/log_strange_acks Received: b'Cap:RUNOUT:0'
2022-07-13 12:27:06,398 Read thread/log_strange_acks Received: b'Cap:AUTOLEVEL:0'
2022-07-13 12:27:06,394 Read thread/log_strange_acks Received: b'Cap:PRINT_JOB:1'
2022-07-13 12:27:06,391 Read thread/log_strange_acks Received: b'Cap:PROGRESS:0'
2022-07-13 12:27:06,388 Read thread/log_strange_acks Received: b'Cap:AUTOREPORT_TEMP:1'
2022-07-13 12:27:06,383 Read thread/log_strange_acks Received: b'Cap:AUTOREPORT_POS:0'
2022-07-13 12:27:06,379 Read thread/log_strange_acks Received: b'Cap:VOLUMETRIC:1'
2022-07-13 12:27:06,375 Read thread/log_strange_acks Received: b'Cap:EEPOM:1'
2022-07-13 12:27:06,371 Read thread/log_strange_acks Received: b'Cap:BINARY_FILE_TRANSFER:0'
2022-07-13 12:27:06,365 Read thread/log_strange_acks Received: b'Cap:SERIAL_XON_XOFF:0'
2022-07-13 12:27:06,360 Read thread/parse_printer_answers Firmware info: b'FIRMWARE_NAME:Marlin 2.1 (Jul 11 2022 15:36:45) SOURCE_CODE_URL:github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:LeftEnder EXTRUDER_COUNT:1 UUID:97fe7eed-2f95-494b-87d1-1f8c51aee253'
2022-07-13 12:27:06,297 Read thread/log_strange_acks Received: b'X:0.00 Y:0.00 Z:5.00 E:0.00 Count X:0 Y:0 Z:2000'
2022-07-13 12:27:05,933 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/preprocess_gcodes Got 4 gcodes to execute.
2022-07-13 12:27:05,931 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/send_homing_gcodes Starting homing thread
2022-07-13 12:27:05,929 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/sync_ready_for_command Syncing ready for command semaphore...
2022-07-13 12:27:03,932 Thread-8 (wait_for_connection_or_timeout)/get_status Report:{'state': 'connecting'}
2022-07-13 12:27:02,950 ThreadPoolExecutor-0_1/start_scan None
2022-07-13 12:27:02,924 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/connect Successful connection to Marlin: {'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}
2022-07-13 12:27:02,923 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/read_greetings Printer is online
2022-07-13 12:27:02,915 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/connect Opened serial port /dev/ttyACM0 at baudrate 250000
2022-07-13 12:27:02,910 Thread-7 (scan)/close Closing printer interface of {'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}
2022-07-13 12:27:02,909 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/connect Connecting at baudrate 250000
2022-07-13 12:27:02,908 Thread-7 (scan)/close Closing detection wizard's device container for:{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}
2022-07-13 12:27:02,907 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/connect Baudrates list for Generic Marlin : [250000, 115200]
2022-07-13 12:27:02,905 Thread-7 (scan)/scan Detection wizard scan thread is waiting for active flag to go down
2022-07-13 12:27:02,905 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/connect_to_printer Connecting with profile: {'alias': 'Marlin', 'baudrate': [250000, 115200], 'end_gcodes': ['M104 S0', 'M140 S0', 'G28 X0 Y0', 'M84'], 'extruder_count': 1, 'min_coords_corner': 'LF', 'name': 'Generic Marlin', 'sender': 'printrun_sender', 'vids_pids': [['0403', '6001'], ['16C0', '0483'], ['2341', '0042'], ['2341', '0010'], ['03EB', '204B'], ['27B1', '0001'], ['1A86', '7523'], ['2341', '003E'], ['0403', '6015']]}
2022-07-13 12:27:02,904 Thread-8 (wait_for_connection_or_timeout)/wait_for_connection_or_timeout Waiting for wizard detector's device container
2022-07-13 12:27:02,902 PrinterInterface{'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}/connect_to_server Connecting to server with printer: {'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}
2022-07-13 12:27:02,900 Thread-7 (scan)/__init__ New printer interface for {'VID': '1EAF', 'PID': '0004', 'SNR': '', 'PRT': '1-1.1.3', 'COM': '/dev/ttyACM0', 'manufacturer': 'LeafLabs', 'product': 'Maple'}
2022-07-13 12:27:02,899 Thread-7 (scan)/force_printer_type Forcing type: None

Alright, thanks.
I had add provided VID/PID to our Ender-3 profile.
Now you need to change the printer type from Generic Marlin to to Creality Ender-3.
If the printer had appeared on page(tab) Printers on cloud.3dprinteros.com, then Tool/Printer Type.
If not, try local webUI using Reset Printer Type button and then Select Printer Type button(can be tricky).
Best regards, 3DPrinterOS Team

@Vladimir The printer never appeared in the cloud; I have still been unable to get past “No printers detected”.

Where would I find a Reset Printer Type button? Once again, as far as the local client UI is concerned, I have NEVER made it past “No printers detected”. I know that the logs show something being detected, but the UI does not and never has.

I’ll try re-imaging the Raspberry Pi and hope that helps.

@Vladimir Ok, that one’s working, thanks!

But we’ve now got another printer that won’t connect. It’s an Ender 5 Pro with a similar board, the BigTreeTech SKR Mini E3 V3.0.

dmesg output is:

[  777.232058] usb 1-1.3: new full-speed USB device number 6 using dwc_otg
[  777.365673] usb 1-1.3: New USB device found, idVendor=0483, idProduct=5740, bcdDevice= 0.00
[  777.365699] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  777.365714] usb 1-1.3: Product: MARLIN_STM32G0B1RE CDC in FS Mode
[  777.365725] usb 1-1.3: Manufacturer: STMicroelectronics
[  777.365735] usb 1-1.3: SerialNumber: 2047365D4D34

New VID/PID added.
Restart your RPi and the printer should appear.
If not(like it was at previous attempt, for some reason), then try to remove file ~/.3dprinteros/printer_profiles.json and then restart.

@Vladimir It’s working, detected, and showing up in Cloud. Thank you SO much!!