New install - wont connect to printers area


Im giving the R Pi image a test run and I’m having some issues. I can SSH to the device, in the tutorials I keep seeing a web interface pop up that looks like its on port 80, but that port is not available on the Pi.

Its also not showing up on the printers list. As I was typing this request for help a similar post showed up. New RPi Client Not Showing Up in My Printers

nobody responded to that request, but I appear to have the same problem.

The post you refer to was mine. The solution was to change the time on the R Pi. The R Pi’s time was not current, and for whatever reason, that kept it from connecting to 3DPrinterOS. As soon as I updated the time and date on the R Pi, it connected immediately. Hope this helps.


The time update issues had been fixed in the images released around a month ago.
Ether download and flash a new image or execute lines on our RPi using SSH:
sudo pacman -Suy (to update the image)
sudo pacman -S fake-hwclock
sudo systemctl enable fake-hwclock

and in case of very old image, also
sudo systemctl enable ntpd

Then, please, reboot with
sudo reboot
And at last, after the reboot, time will sync in about 5-10 minutes(first time in is a bit slow).
Afterwards it will be instant.

Hope that this will help you to solve the issue
Best regards, 3DPrinterOS Team