M601 not recognized, printer continues printing air

Sending an M601 command does not properly pause the printer. The status line updates to “Print paused”, but the printer is observed continuing XYZ motion with a cold extruder.

Use case: I want to encapsulate magnets in a print without changing the filament.

Hello. We have already seen this issue for Prusa Mini. It is a firmware bug. It doesn’t support it on printing via USB and printer just ignores it.

What printer type do you have? I can see from the screenshot that it is Prusa MK3S, isn’t it?

The possible solution is to enable emulated pause in the 3DPrinterOS Client:
To change it you will need to go to 3DPrinterOS Client web interface (RPI IP in browser, or for PC versions of Client it is in browser)
Then you need to go → Settings (on top of the left menu) → Edit settings file → Look for “intercept_pause” parameter and change it to true
After that click Save and then restart the Client to apply new settings (!!!when you will have no printing jobs on this Client!!!)

Yes, this is regarding a Prusa MK3S.

I’ll try your suggestion and report back, thanks!