Issue Port Forwarding

Hi there!

I’ve been given the task of evaluating 3DPrinterOS for the print farm I work for.

The plan is to create a headless setup using a Ryzen powered Mini PC running Ubuntu Server, that controls about 22 printers.

I managed to get the client installed, auto starting up on boot, but I can’t access the control panel to log in over my local area network.

I port forwarded 8080 but I can’t reach it from any of my other computers.

Are there additional ports I need to forward? I need to be able to log the client into the cloud remotely.



  1. If you wish to control 3DPrinterOS Client from the cloud, then please make sure that and machine running it can connect to port 443 of our cloud server (just in case is you are banning outbound connection for some reason)

  2. To enable a remote web UI, you will need to change a settings file. That is because by default the 3DPrinterOS Client for Ubuntu is configured to have a local web UI accessible only from localhost.
    To do so, please, close 3DPrinterOS Client.
    Then edit file ~/.3dprinteros/user_settings.json
    …(just in case, ~/ is alias to your home folder and .3dprinteros is a hidden folder)…
    And change following:
    “remote_control”: {
    “broadcasting”: false,
    “detectable”: false,
    “web_server”: false
    “remote_control”: {
    “broadcasting”: false,
    “detectable”: false,
    “web_server”: true

  3. The port you had mentioned(8080) is NOT the one used for local web UI. A correct one would be port 8008. Please check if there is an issue there.

  4. You will have to login in your client from localhost one time. After this a remote control will be be possible using the same credentials.

Best regards,
3DPrinterOS Team