Choose left extruder on Makerbot 2X

Is it possible to print with the left extruder ony on a Makerbot 2X? I try to choose the left extruder instead of the right in the advanced settings and it is grayed out and cannot be chosen.

Hey Keven! Are you sure you have the Makerbot 2X driver selected in the settings?

The Makerbot 2X and the Makerbot 2 use exactly the same control board, so the makerbot 2 drivers work on the 2X, but it just wont activate the heated bed or second extruder.

Which settings are you referring to? I have the Replicator 2X selected here, but still can’t choose left extrduer.

Hey Keven, Ive confirmed this on my end, It looks like there is a bug here, Il try to get this fixed for you within the next couple of days.

Any Updates on this?

Im not sure yet, Il get back to you about this.

Same question. I have the replicator dual and I can only select the right extruder for some reason…

Same question here. I’m not particularly interested in dual extrusion however my right extruder is INOP and I really don’t want to take the whole thing apart to switch the two extruders.

Any way to switch over to the left one?


Max, Similar question. I would like to use both the left AND right extruders on the same print. I’d like to use the left for supports (using dissolvable filament) and the right for the actual object (ABS.)

Hello. 3DPrinterOS Cloud Slicer don’t support changing extruder for this moment. But dual extrusion is currently in active developing.

For this moment to change extruder for Makerbot printers you can try to use our new slicer application “Slicer for Makerbots”. There is no extruder selecting on Simple or Advanced tabs, but you can change them in Expert tab. When you selected printer type and some of default slicing profiles, you can go to Expert tab and change next parameters:

"defaultExtruder": 0, (extruder number for your model: right=0, left=1)
"defaultRaftMaterial": 0, (extruder number for raft)
"defaultSupportMaterial": 0 (extruder number for supports)

If you leave this settings as is - only right extruder will be used. Changing all of that parameters to 1 - only left extruder will be used. Changing only some of them then both extruders will be used in printing.

Changing of this parameters will properly work only for Makerbot printers with dual extruders: Makerbot Replicator 2X and MakerBot The Replicator (Dual). In any case please make some small testing before printing something big and cool)

We can add default slicing profiles to “Slicer for Makerbots” application with only left extruder selected too, if it will be useful for anyone.

Please let us know if this information is helpful for you. Happy Printing)

1 Like

Hi M.Kozlov,

“_attached_extruders”: [
“_bot”: “replicator2x”,
“_extruders”: [
“_materials”: [
Above is the beginning code in the expert section for the Slicer for Makerbots It looks like it needs to add the left extruder.
Here is the revsion that I think is needed:
“_extruders”: [
0, 1

So as you can see, I added , 1 which I think is adding the left extruder. Do I need to add this code to have the printer realize that there are two extruders?

Also, I tend to use HIPS for support material in my left extruder. Should I change the code below to include this?
“_materials”: [

Hello. As I know changes that I wrote before is enough for dual printing. In any case you can try what you want and check the gcode file content

Hello. About hips. Yes it looks that you need to change _materials section to use hips+abs materials. As I understand for HIPS material in left extruder and abs in right you need to do:
“_materials”: [
But try it on some small model for testing

Please update me on how it goes :slightly_smiling: