Printrbot Metal Simple slicer default starting gcode issue

Here is the default starting gcode for the Printrbot Metal SImple:
“startCode”: “M104 T0 S{print_temperature}\nM109 T0 S{print_temperature}\nG28 X0 Y0\nG29\nG92 E5\nG1 E0 F600\nG1 Z0.8 F2000\nG28 Y0 X0\nG1 E8 F300\nG1 Y30 E25 F300\nG1 E24 F800\nG92 E0”,

I’m having trouble with the fact that the G28 X0 Y0 command is run again AFTER the G29 command.

G28 X0 Y0
G29

G28 X0 Y0

Although I can’t find any substantial documentation that proves it, my experience is that if you run G28 AFTER the G29 command, it resets the G29 adjustments.

I know that I can just create my own custom profile to change the startCode, but I have over 30 middle school students who share the workgroup printers. And I have to explain to each one of them how to change the expert setting to remove the 2nd G28 X0 Y0 from the startCode (in fact I just remove everything after the G29 command).
I would really appreciate it if you could remove that 2nd G28 X0 Y0 code from the startCode and use a different command to return the extruder to the 0,0 position.

I do think that it is wrong the way that it is.

Hi, fixed. I removed the G28 X1 Y1 for Experimental - High profile, please test and tell is it ok now?

Yes, the Experimental - High profile works great now, thanks! I can see the z height adjustments while it is printing. Will you also be changing the other printrbot metal simple profiles? (Note, the printrbot play profiles did not have the issue)