Pi Camera not working

I’m trying to get up and running on a Pi3. I followed the directions here to set up the Pi. At first I wasn’t able to see the Pi Camera at all. My startup looked like this:

Launching 3DPrinterOS
Creating new instance of Config
File logger created: /root/.3dprinteros/3dprinteros_client.log
Starting 3DPrinterOS client. Version 6.0.15stable. Build 105.
Operating system: Linux 4.19.66-v7+
Server: cli-cloud.3dprinteros.com
Installed plugins:
[{u'enabled': True, u'display_name': u'Makerbot', u'name': u'makerbot'}]
Loading plugin: makerbot
Connecting from: 192.168.1.232 00000000f971aa02
Successful login from user xxxxxxxxxxx@xxxxx.com
Starting web server...
Waiting for webserver to start...
...web server started on port: 80
...web server started on port: 443 (HTTPS)
...server is up and running.
Waiting for timeout or login to open browser...
...done
Creating listen socket for port 5168
Waiting for an action: User login
...end of waiting for: User login
Launching camera subprocess
Camera started: Pi camera
Stored printers list: {
"added_by_ip": [],
"detected": []
}
Creating new instance of Config
INFO:http_client:Connecting from: 192.168.1.232 00000000f971aa02
Can't init PiCamera. Camera seems to be not connected or not enabled in RPi config.
WARNING:camera:Can't init PiCamera. Camera seems to be not connected or not enabled in RPi config.

I was able to use command line utils to get an image captured so I knew the camera was working (i.e. no loose/flipped cables, etc). Then I found a recommendation to run apt-get install python-picamera. It seemed like that made progress but now when I select the camera, I get a nonstop block of this in the terminal window:

WARNING:http_client:Warning: HTTP request failed!
INFO:http_client:Connecting from: 192.168.1.232 00000000f971aa02
Error N8. Error: server responded with non 200 OK
Full response: <html>
<head><title>502 Bad Gateway</title></head>
<body bgcolor="white">
<center><h1>502 Bad Gateway</h1></center>
<hr><center>nginx</center>
</body>
</html>

WARNING:camera:Error N8. Error: server responded with non 200 OK
Full response: <html>
<head><title>502 Bad Gateway</title></head>
<body bgcolor="white">
<center><h1>502 Bad Gateway</h1></center>
<hr><center>nginx</center>
</body>
</html>

So I uninstalled that but I’m back to the “Can’t init PiCamera message.” Any ideas?