Issues With Build Volume And Start Gcode

I have two Hyvision Cubicons, and they print well with 3DPrinterOS. They work with the Generic Marlin printer choice.

The first issue is that the build volume is wrong, how can I edit this? I need a build volume of; 239 x 190 x 200 mm as opposed to the; 200 x 200 x 100 mm that it has now. Files are printing on the side rather than the middle because of this, and I can’t use the full height of my build volume either.

The other issue that I am having is that the Cubicons have a heated build chamber and 3DPrinterOS doesn’t support this right now. I have been trying to put the GCode into the start section on the Expert settings panel however it always resets and removes the GCode whenever I try to save.

How can I fix these issues? Thanks.

Looks like your printer hasn’t been integrated.
Please fill out this form:

Hi, integrated now, please try slicing/printing

Hey, thanks! It’s working a little better now, but things still print a little bit left of middle, and it still doesn’t control the chamber heater. Is there a way that I can edit the start GCode myself?

please send starting gcode, I will integrate them

Start gcode:

M911 3DP-110F
;M901
M910 S52009
M914 S115200
M915 S13019494
M107
M201 X400 Y400
M202 X400 Y400
M901 S55
M190 S{Bed Temperature}
M109 T0 S{Extruder Temperature}
T0
G21
G90
G28 X0 Y0 Z0
G92 E0
G1 F100 E5
G92 E0

End gcode:

M104 T0 S0
M140 S0
M904
M117 Print completed!
M84

Hey, I have integrated start and end gcode to Experimental profile, please test.

Hey Anton, for some reason things are still printing left of center, and the chamber heater still isn’t heating up. Not sure what the problem is.

Also I have been having a problem setting up my Raspberry Pi B, and Pi 2 over Wifi. I connect to the 3dprinteros wifi network and go to 10.10.0.1/wifi, but when I try to login with the information provided in the email it doesn’t work. Just keeps asking me for the login over and over. I have tried both “pi” and “root” as the username.