Connectivity issues regarding Mac?

A lot of the issues around connectivity to printers reported are on older Mac’s (Older then 10.10.1)
If you are using a Mac we would recommend upgrading to 10.10.2 or newer.

Please upgrade your mac software to 10.10.2 to get optimal performance with 3DPrinterOS.

Mac 10.10 is so full of bugs it’s not worth the headache just to use 3DPrinterOS. Most Mac software always says compatible with10.8 and newer.

At some point of time you may face connectivity issues with your mac os because of some driver update problems which you can easily get from apple customer service number and you can visit the official site too.